Recover from Microsoft Office Setup Error 

Observations

When you try installing Microsoft Office or run the program for the first time, you receive the following error messages: 

· Fatal error during installation

· This patch package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer patch package

· The feature you are trying to use is on a CD-ROM or other removable disk that is not available. Insert the Office XP product disk and click OK

· This patch package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer patch package

· The installation source for the product in not available. Verify that the source exists and that you can access it

· This patch package could not be opened. Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package 

Possible Causes

This is a result of a registry conflict when it contains previous Microsoft Windows Installer information from an earlier Office installation.

Resolution

You can resolve the issue by running the Windows Installer CleanUp utility to remove the Windows Installer registry settings, and then reinstall Office. 

To do this, follow these steps: 

1. Download the Windows Installer CleanUp utility from Microsoft

2. Execute the program 

3. To use the Windows CleanUp utility, follow these steps: 

· Click Start, select Programs, and then select Windows Install Clean Up
· Select the program that you want to remove, and then click Remove
· Click OK, and then click Exit
· Run Office Setup to reinstall Office 

Recover from Microsoft Powerpoint Data Corruption

Observations

When you open your Powerpoint presentation file, Powerpoint halts or terminates and you receive the following error(s):

“PowerPoint cannot open the type of file represented by filename.ppt.” 

"This is not a PowerPoint Presentation" 

"Your system is low on virtual memory. To ensure that Windows runs properly, increase the size of your virtual memory paging file." 

"Part of the file is missing." 

Possible Causes

The file is corrupted. Check if this file is sent to you as an email attachment through the Internet as files have the tendency to corrupt if they are being transmitted via cyberspace. To deal with this, users can make use of Windows XP's build in Zip function tool or a 3rd party software such a winzip to protect the file before sending across. Also check if you're running an earlier version of Powerpoint to view a file that was created with a newer version of Powerpoint. As prevention is better than cure, you may want to know the right way to reduce the chance of Powerpoint corruption.

Resolution

There're several methods to salvaging a corrupted Powerpoint file and hopefully recover some data back. 
a. Use Slides from Files 
1. Open Microsoft Powerpoint 

2. Open a new blank presentation

3. On the Insert menu, click Slides from Files


4. In the Slide Finder dialog box,select you corrupt file

5. Click Insert All

If clicking Insert All does not work, try clicking Insert to insert individual slides

b. Locate a TMP file
Occasionally when you lose your file, there may be a TMP file available. This usually only happens when you lose the file while saving, or if you were working on it when PowerPoint or Windows crashed. Nevertheless, it’s worth checking. 

1. Click Start, point to Search, select Files Or Folders
2. In the All or part of the file name box, type *.TMP
3. Click Search
4. At the search result, click the Date Modified button at the top

You might have to scroll to the right to see this button. 
5. Look for a TMP file with the time stamp that is about the time you lost your PowerPoint file and note the location of the file
6. Open PowerPoint, and then select Open on the File menu. 
7. Click the arrow next to the Files of Type box at the bottom of that dialog box, and then click All Files
8. Navigate to the folder where the TMP file is located
9. Select the TMP file, and then click Open
c. Open the presentation in Word
Some text may be recovered by using this method. 

1. Open Microsoft Word. 
2. On the File menu, click Open. 
3. Under the Open dialog box, click the arrow next to the Files of Type box at the bottom of that dialog box, and then click Recover Text From Any File. 
4. Select your corrupt file, select it, and then click Open. 

d. Using Powerpoint Safe Mode
Try opening Powerpoint in Safe Mode and see if that enables you to open the file.

1. Click Start, point to Run 

2. Type in: powerpnt.exe /safe
3. Open the corrupted file 

Powerpoint Corruption Prevention

There is no 100 percent method to prevent data file corruption. Disks wear out gradually, power supplies fail, and software conflict are some of which that cause file corruption. This article will discuss several ways to reduce your Powerpoint files from being damaged. 

· Do not Work Directly On Removable Media

Refrain from working your data directly on removable media such as Floppy disks, CD-ROMs, Zip or Jaz disks, USB flash drives. Only use these removable media as backup or to transport the data. 

It is a good practice to use Windows Explorer to copy the required data file to your hard drive, and then open and work on it from there. Upon finishing your work, save the data file from the hard disk drive back to the removable media. 
· Make Backups 

It is a good practice to always use the Save As command on the File menu (rather than the Save command) to save the file with a new name. In this way you always have a previous version to go back to in case you make a mistake that overwrites the earlier contents.
· Ensure Constant Power Supply 

An inconsistent power supply can cause corruption in files, even if the power does not completely go out. If the power supply spikes or is not sufficient, it can affect the read/write processes of your computer, resulting in corruption. If the power supply in your area is inconsistent, purchase a surge protector. Surge protectors are relatively inexpensive and will help protect your system from power spikes. You may also consider investing in an uninterruptible power supply (UPS). UPS units supply your computer with power even during a power outage.
· Practice Good Hard Drive Maintenance

Standard practices include deleting of .TMP files, emptying the recycle bin, deleting Temporary Internet Files folder and performing disk scans for virus and spyware. 
· Zip files Before Sending Though E-mail

It is a good practice zip the file before sending it as attachment. This will reduce the file size and hence the chance of data corruption.
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(Or you could use the Winzip program to compress the file before sending as attachment) 

Recover From Microsoft Word Startup Error

Symptoms

You launch Microsoft word and receive the following errors:
· HRESULT: 0x8001010A
VB Error: -2147417846
"The message filter indicated that the application is busy" 
· HRESULT: 0x800A175D
VB Error: 5981
"Cannot open macro storage" 
· HRESULT: 0x800A142D
VB Error: 5165
"Word cannot open the existing [square]" 

Possible Causes

The followings are the two common causes to the problem: 
a. Normal.dot Corruption
b. Software Corruption 

Resolution
a. Normal.dot Corruption

The normal.dot file is a global template file. Microsoft Word locates this file each time it initialises.

To resolve this issue, follow these steps: 
1. Click Start, point to Search, select Files Or Folders 

2. Type in: Normal.dot and hit Enter 

Where <folder> differs from various operating system, the typical file path is C:\<folder>\Application data\Microsoft\Templates. If you are using Windows XP, normal.dot is marked as a hidden system file and may not show. You are therefore required to enable to view hidden files.
3. Once you locate the file, rename it to Normal.dot.old
4. Restart Microsoft Word and the new Normal.dot template will be automatically created 

b. Software Corruption 

This can occur when certain important structures of Microsoft Word is corrupted. The best way to repair software corruption is to perform a full reinstallation. 

Recover From Microsoft Word Data Corruption

Observations

After opening a word document it exhibits unusual behaviour such as displaying an incorrect layout, formatting, repeated line-breaks, gibberish characters and error messages when Word processes the file.

Possible Causes

The document file is corrupted. This can be caused by a macro virus infection or conflicting software that incorrectly modifies the file.

Resolution

These are several methods to recover a corrupted document. You may lose certain formatting and macro codes on your document. Nevertheless, you can salvage majority of the information. 

a. Save Document To Another File Format 
1. Open the corrupted file with Microsoft Word

2. Save the file to another file format such as Rich Text Format (.rtf) or plain text (.txt)

3. Close the document and reopen the file in Microsoft Word

4. Save it as a new Word document (.doc)

b. Copy All Except The Last Paragraph Mark To A New Document 
1. Open the corrupted file with Microsoft Word 

2. Press CTRL+END, and then press CTRL+SHIFT+HOME

If your document contains section breaks, copy only the text between the sections breaks. Copying the section breaks may carry the damage over into your new document. To prevent this, try viewing the document in Normal view. 

To do this, click Normal on the View menu.

3. Copy and paste the content into a new document

c. Force Recover Corrupted Document 
1. Open Microsoft Word

2. On the File menu, click Open
3. Browse and select the corrupted document 

4. Click the arrow on the Open button, and then click Open and Repair
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d. Insert The Document As A File In A New Document 
1. Open Microsoft Word

2. On the File menu, click New and select Blank Document 

3. On the Insert menu, click File
4. In the Insert File dialog box, locate and select the corrupted document, and then click Insert
e. Recover Text from Any File Utility 
1. Open Microsoft Word

2. On the File menu, click Open
3. In the Files Of Type, select Recover Text From Any File
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4. Browse, select the corrupted document and then click Open 

f. Open The File In WordPad 
1. Click Start, point to Programs, point to Accessories, select WordPad
2. On the File menu, click Open and select the damaged document 

3. The word document will open and you may see some random binary strings at the start and at the end of the document. Delete them with other characters that do not belong to the document.

4. On the File menu, click Save As
5. In the File Name box, type a new filename and save it as a (.doc) format. 

6. Restart Word

7. Open the newly saved file and re-save it as a word document. 

Recover From Microsoft Excel Startup Error
Observations

You're unable to startup Microsoft Excel. 

Possible Causes

This behaviour may be attributed to the following reasons:

a. Corrupted Shortcut to the Excel Program
b. Corrupted Excel toolbar file (*.xlb)
c. Corrupted Excel file (*.pip)
d. Corrupted add-ins under the Tools menu
e. Corruption in Excel Startup Folder or Registry Keys 

Resolution

a. Corrupted Shortcut to the Excel Program
1. Close any Microsoft Office programs

2. Click Start, point to Search, and then select For Files or Folders
3. Type in: Excel.exe
4. When Excel.exe is located, double-click on the file

If Microsoft Excel starts up, we can conclude that an error in your shortcut has occurred. To resolve this, create a new shortcut to the Excel program. 

To do this, follow these steps: 

· Right click on the Excel.exe file

· Select Create Shortcut 

If Excel does not start as mentioned in step 3, follow the remaining steps to run Excel in Safe Mode. 

5. Click Start and select Run 

6. Type in: excel.exe /s 

If Microsoft Excel starts when you use the /s switch, "Safe Mode" appears in the Excel title bar. This indicates Microsoft Excel is running as if it were the first time after the initial installation.
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Now that you have started Excel, use a process of elimination to step through the following areas that Excel bypasses in Safe mode, until the problem is corrected.

b. Corrupted Excel Toolbar File 

Excel stores information about custom toolbars in the toolbar file. A damaged toolbar file can cause problems during startup.

To solve this, follow these steps

1. Click Start, point to Search and select For Files or Folders 

2. Type in: *.xlb
3. When the file is located, rename it

By default where <folder> differs from various operating system, the toolbar file is stored in C:\<folder>\Application Data\Microsoft\Excel\. Restart Microsoft Excel and a new toolbar file will be created. 

c. Corrupted Excel.pip File
Excel remembers the recent menus and commands that you have used and displays them first. Excel hides the unused commands in its expandable menus. These information along with menu animation settings in stored in a file named Excel.pip. A corrupted Excel.pip file can cause startup problems.

To resolve this, follow these steps: 

1. Click Start, point to Search and select For Files or Folders 

2. Type in: Excel.pip
3. Rename the file to Excel.pip.old 

4. Restart Microsoft Excel and the new (.pip) file will be created 

d. Corrupted Add-ins 
To check if the corrupted add-ins are responsible for the errors, follow these steps: 

1. Click Start, point to Run
2. Type in: excel.exe /automation

If Microsoft Excel startup, we can conclude that your add-ins are corrupted. 

To resolve this issue, follow these steps:

3. Open Microsoft Excel

4. Select Add-Ins under the the Tools menu

5. Clear the check boxes that contains the add-ins 

6. Click OK 

7. Next remove the following registry keys: 

· Click Start and select Run
· Type in: regedit or regedt32 (exclusively for Windows 2000) 

· Navigate to the following paths:

The location of the registry path will depend on the version of Microsoft Office installed

· Excel 2003 
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\11.0 

· Excel 2002 
HKEY_CURRENT_USER\Software\Microsoft\Office\10.0
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\10.0 

· Excel 2000 
HKEY_CURRENT_USER\Software\Microsoft\Office\9.0
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0 

e. Corruption in Excel Startup Folder or Registry Keys 

Use the Detect and Repair utility to repair any corruption. To do this, follow these steps:

1. Insert your Office Installation CD into your computer

2. At the Setup menu, select the option to repair Excel 

More Information 

This article only applies to:

· Microsoft Excel 2000 

· Microsoft Excel 2002 

· Microsoft Excel 2003 

Recover From Microsoft Excel Workbook Corruption

Observations

Microsoft Excel workbook files do not open correctly. You may receive the following error message:
· Cannot find the file or one of its components. Make sure the path and filenames are correct and that all required libraries are available. 

Possible Causes

The workbook files are corrupted. 

Resolution

These are several methods to recovering corrupted Excel files.
a. Backup the copy before attempting the recovery 
1. Click Start, select Programs, select Microsoft Office, select Microsoft Office Tools, and then select Microsoft Office Application Recovery
2. In the Application list, click Microsoft Excel, and then click Recover Application
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b. Use the "Open and Repair" Command

This method is the primary method of file recovery in Excel 2002 and later versions. To do this, follow these steps: 
1. Start Excel
2. Under File menu, select Open
3. In the Open dialog box, select the file that you want to open. 
Click the arrow on the Open button, select Open and Repair
4. When you are prompted, click Repair to recover your most recent changes
5. Finally save your recovered workbook

c. Open the File in Word or WordPad

This method does not recover any module sheets, dialog sheets, chart sheets, macro sheets, or any embedded charts and only the results of those formulas that are currently in the cells. To do this, follow these steps: 
1. Open Microsoft Word or WordPad
2. On the File menu, click Open 

3. Under Files Of Types, select All Documents or All Files 

4. Browse and select the corrupted excel file 

More Information

This article only applies to:
· Microsoft Excel 2002 
· Microsoft Excel 2003 

